The Dreaded 70% and 98% Magento 2 Install Pauses (Quick Note)

Magento Installer Pause

You are installing the Magento 2 Merchant Beta (sweet!) with the Luma Store sample data, and the web installer pauses at 70%. Is it dead you wonder? For me, I waited and it got past this step and continued onwards. But then I hit the 98% pause.

I waited.

I waited a bit longer.

Ummm. Is it still alive?

The answer for me was yes, but how to check it was still doing work? What I did was click the “Console Log” button to show the log and scroll right to the end. You should see something like:

Installing bundle products:
.
Installing downloadable products:
......
Installing grouped products:
.
Installing configurable products:
..............................................

If you watch closely, you should see additional dot appearing say every 10 seconds or so. If this is happening, everything is still working. Just be patient and let it load up all that sample data, and accept our apologies the percentage progress bar is not more accurate.  The web installer does not take into account some steps take longer than others, so pausing at 70% and 98% when loading sample data is the norm.

Oh, and by the way, my laptop did complete the install successfully, but it took around 150 dots. And most of the time was with the progress bar at 98%.

The moral of this story? Good things come to he who waits.

8 comments

  1. Thanks. Waited for 150 dots and it worked!

  2. Sarjan Gautam · · Reply

    Thanks for the post. My installation has paused at 66% and dots does not seems to be increasing.

    Module ‘Magento_Worldpay’:
    Installing user configuration…

    1. This post was definitely before ga, so may be no longer relevant. I would check available memory – it does work for many. So most likely something about environment.

  3. he web installer pauses at 87%. Is it dead you wonder? For me, I waited and it got past this step and continued onwards. But then I hit the 98% pause.

  4. stuck on 97% and no dot shows.

    1. Try looking in var/log. Some people have found errors such as running out of memory of other similar things in that log. Otherwise try looking through GIT hub – there are a few people with similar problems who found similar solutions. (Increasing memory limits etc.)

  5. rohitsavaliyaom · · Reply

    it is stuck on 97% and no dots show
    what should i do…….

    1. Rakesh Shewale · · Reply

      Try looking in var/log. Some people have found errors such as running out of memory of other similar things in that log. Otherwise try looking through GIT hub – there are a few people with similar problems who found similar solutions. (Increasing memory limits etc.)

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: